Please don't damp me!

Discuss any questions about BEPUphysics or problems encountered.
Post Reply
Nablablan
Posts: 9
Joined: Fri Jun 23, 2017 9:46 am

Please don't damp me!

Post by Nablablan » Tue Jul 04, 2017 10:44 am

Hi,

For my things in my space game, I dont want them to be dampened at all ( unless the user chooses to)
So if some space junk rotates, even the slightest, I want that to go on for ever.
There is no energy/jitter problem bc there is no gravity.
So I have set Lin/AngDamping to 0.0f, but it still stops at low speeds.

I found this code in the engine (EntityBase.cs)

Code: Select all

 float linear = LinearDamping + linearDampingBoost;
As I understand it, it dampens very slow moving stuff.
Can I disable it?
Would be ok if its disabled for the whole space

Best regardies

Norbo
Site Admin
Posts: 4508
Joined: Tue Jul 04, 2006 4:45 am

Re: Please don't damp me!

Post by Norbo » Tue Jul 04, 2017 6:49 pm

Yup, you can disable it. Set the Space.DeactivationManager.UseStabilization to false.

Nablablan
Posts: 9
Joined: Fri Jun 23, 2017 9:46 am

Re: Please don't damp me!

Post by Nablablan » Fri Jul 07, 2017 9:04 am

thanks! That saved time :)

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest