Search found 10 matches

by ntd master
Tue Oct 25, 2011 12:08 am
Forum: Questions and Help
Topic: Angular Velocity from WorldTransform
Replies: 2
Views: 990

Re: Angular Velocity from WorldTransform

Ah, cool. It sounds like EntityRotator may be just what I was looking for.
by ntd master
Mon Oct 24, 2011 9:51 pm
Forum: Questions and Help
Topic: Angular Velocity from WorldTransform
Replies: 2
Views: 990

Angular Velocity from WorldTransform

Hey Guys,

Is there a good way to extract rotation data from a WorldTransform, so that I could apply it to an entity's angular velocity?
by ntd master
Mon Oct 24, 2011 7:56 am
Forum: Questions and Help
Topic: Using a DetectorVolume with Kinetic Entities
Replies: 6
Views: 1326

Re: Using a DetectorVolume with Kinetic Entities

Ah, so I wasn't completely just making things up in my head (always a good thing). Another possibility: if the bounding box is somehow not being updated or the entity is otherwise unfindable by the broad phase query accelerator, the DetectorVolume would not detect anything. Hm...I don't think that w...
by ntd master
Mon Oct 24, 2011 7:06 am
Forum: Questions and Help
Topic: Using a DetectorVolume with Kinetic Entities
Replies: 6
Views: 1326

Re: Using a DetectorVolume with Kinetic Entities

Hey Norbo, It looks like I might have found the issue. I was moving the kinetic entity around by updating it's world transform every update, instead of just trying to move it around purely using velocities. After doing a quick test with only velocity based movement, it looks like it's detecting coll...
by ntd master
Mon Oct 24, 2011 6:10 am
Forum: Questions and Help
Topic: Using a DetectorVolume with Kinetic Entities
Replies: 6
Views: 1326

Using a DetectorVolume with Kinetic Entities

Hey guys, I have a scenario where I have one box shaped DetectorVolume that doesn't currently move, and one box shaped kinetic entity that I can control with user input and move around. I'd like to detect and have an event go off whenever the kinetic entity does any kind of colliding with the Detect...
by ntd master
Thu Oct 06, 2011 8:50 pm
Forum: Questions and Help
Topic: Deforming a StaticMesh
Replies: 2
Views: 1203

Re: Deforming a StaticMesh

Hey Norbo, Thanks for the help. I had fooled around with Reconstruct a little, but as you mentioned it creates garbage and definitely was slower so it didn't really give me the results I was looking for. Refit() seems to work great though, so it looks like I can just use that. So now after I get my ...
by ntd master
Thu Oct 06, 2011 6:04 am
Forum: Questions and Help
Topic: Deforming a StaticMesh
Replies: 2
Views: 1203

Deforming a StaticMesh

Hey guys, I was wondering what the best way is to deform a StaticMesh at runtime. Is there a good way to do it? Right now all I can think of is to re-calculate my StaticMesh's vertices and indices everytime it gets a crater like impact that deforms it...and then remove the StaticMesh, and create a n...
by ntd master
Wed Apr 20, 2011 3:13 am
Forum: Questions and Help
Topic: Characters, Ramps, and Ladders
Replies: 2
Views: 1083

Re: Characters, Ramps, and Ladders

Thanks for the help. I'll have to take another look at MaxSlope, though by the sounds of it I might be having a problem with the raycast hanging...so I'll definitely have to check that.

Also the rail idea is curious and is something I'll definitely have to test out. Good stuff.
by ntd master
Tue Apr 19, 2011 11:34 pm
Forum: Questions and Help
Topic: Characters, Ramps, and Ladders
Replies: 2
Views: 1083

Characters, Ramps, and Ladders

Hey guys, I'm currently using the SimpleCharacterController from version 0.15.2 and I'm having an issue with some of my movement. Some of the buildings in my game have somewhat steep ramps or 90 degree ladders that I'd like the player to be able to climb at the same speed as the normal walking speed...
by ntd master
Wed Nov 24, 2010 9:44 pm
Forum: Questions and Help
Topic: Displaying Terrain in ModelDrawer v0.14.3
Replies: 0
Views: 6188

Displaying Terrain in ModelDrawer v0.14.3

Hey guys, I just wanted to give everyone a heads up regarding a debugging issue I came across. If anyone is using the ModelDrawer to help debug and/or align physics to their graphics and in particular tried to align their terrain heightmap, they might've noticed that in v0.14.3 their heightmap tends...